0 votes
19 views
I tried to return to a notebook that I had that finds objects in ls_dr7. When I perform an svc.search, it tries to do it for a few minutes but will return with a chain of errors, all of them being something along the lines of Timeout Error, Max Retry Error, Connection Error. This exact same code worked about 2 months ago. I tried this in both jupyterlab and the classic jupyter interface.

Here is what you need to run it:

DEF_ACCESS_URL = "http://datalab.noao.edu/sia/ls_dr7" # DES SIA service URL
svc = sia.SIAService(DEF_ACCESS_URL)

ra,dec = 356.12546,0.320592
fov=0.05
imgTable = svc.search((ra,dec),(fov,fov), verbosity=2).to_table()

Thanks
asked Nov 11 by anonymous | 19 views

1 Answer

0 votes
Thank  you for contacting us.  The service was overloaded, so we rehosted it.  Things should be working again.

Let us know if not.

Thank you,

Adam
answered Nov 11 by ascottdemo (860 points)
Hey Adam,

I got the same error. Let me know if there's anything I can do on my end.

I'll just copy/paste the last of multiple errors it returns in case this helps:
DALFormatError: ConnectionError: HTTPConnectionPool(host='datalab.noao.edu', port=80): Max retries exceeded with url: /sia/ls_dr7?POS=356.12546%2C0.320592&SIZE=0.05%2C0.05&FORMAT=ALL&INTERSECT=OVERLAPS&VERB=2 (Caused by NewConnectionError('<urllib3.connection.HTTPConnection object at 0x7f5590d25250>: Failed to establish a new connection: [Errno 110] Connection timed out'))

Thanks,
Derrick
Thanks Derrick,

try restarting your Kernel.   I was having similar issue, but it started working after restarting the kernel.
Let me know if it still gives you trouble.
Hey Adam,

Still having the same issue after restarting the kernel a few times.

-Derrick
Thank you for getting back to me.

Use  https instead of http:  "https://datalab.noao.edu/sia/ls_dr7"
Fixed it! Thanks Adam.
Great!  Thanks for letting us know.
Hey Scott,

Sorry to bother you again, but it seems like the svc.search command stopped working again. It worked perfectly fine last night, but now when I try to run it again without making any changes I get:

DALQueryError: cannot read properties file (dalserver.properties)

To be clear, here are the relevant commands

DEF_ACCESS_URL = "https://datalab.noao.edu/sia/ls_dr7" # DES SIA service URL
svc = sia.SIAService(DEF_ACCESS_URL)

ra,dec = 133.68635,4.301955
fov=0.05
imgTable = svc.search((ra,dec),(fov,fov), verbosity=2).to_table()

This should be identical to my original question except I added the s in the right place.
Hi Derrick! Not a bother at all.   Thanks for letting us know.
We found the issue and it is resolved now.
Let us know if something's amiss.  
Cheers,
Adam
Hey Adam

It seems the svc.search isn't working again. I got this error now.

DALServiceError: 404 Client Error: Not Found for url: https://datalab.noao.edu/sia/ls_dr7?POS=133.68635%2C4.301955&SIZE=0.05014126928660507%2C0.05&FORMAT=ALL&INTERSECT=OVERLAPS&VERB=2

The input is identical to the one above.
Thanks again Derrick.  It's working now.  We don't anticipate further issues, but if there are any please don't hesitate to ask.

We thank you for your patience.

Adam

206 questions

204 answers

198 comments

1,396 users

Welcome to Data Lab Help Desk, where you can ask questions and receive answers from other members of the community.